Here I’m going to list all the errors/fixes during the an prechecks/upgrade to 26ai:
1:- Error during “gridSetup.sh -silent -upgrade -executePrereqs”
[oracle@rac-ol8-01 ~]$ /u01/app/26ai/grid/gridSetup.sh -silent -upgrade -executePrereqs
Launching Oracle Grid Infrastructure Setup Wizard...
*********************************************
Hard Limit: maximum open file descriptors: This is a prerequisite condition to test whether the hard limit for maximum open file descriptors is set correctly.
Severity: CRITICAL
Overall status: OPERATION_FAILED
-----------------------------------------------
-----------------------------------------------
Error message: PRVG-0341 : Failed to retrieve the current login shell from nodes "rac-ol8-01"
Cause: An attempt to retrieve the current login shell from indicated nodes failed.
Action: Ensure that the required login shell settings for current user are correct on the indicated nodes.
*********************************************
Soft Limit: maximum open file descriptors: This is a prerequisite condition to test whether the soft limit for maximum open file descriptors is set correctly.
Severity: CRITICAL
Overall status: OPERATION_FAILED
This error is because process tries to ssh to itself and it needs password input, to avoid that, this is the fix:
[oracle@rac-ol8-01 ~]$ cd .ssh/
[oracle@rac-ol8-01 .ssh]$ cat id_rsa.pub >> authorized_keys
[oracle@rac-ol8-01 .ssh]$
[oracle@rac-ol8-01 .ssh]$ ssh rac-ol8-01
Activate the web console with: systemctl enable --now cockpit.socket
Last login: Fri Oct 2 16:42:46 2026
[oracle@rac-ol8-01 ~]$
** repeat the same on each rac node.
2:- Error during “gridSetup.sh -silent -upgrade -executePrereqs”
[oracle@rac-ol8-01 ~]$ /u01/app/26ai/grid/gridSetup.sh -silent -upgrade -executePrereqs
Launching Oracle Grid Infrastructure Setup Wizard...
....
Error message: PRVH-1546 : Grid Infrastructure Management Repository database resource is configured in the source CRS home "/u01/app/oracle/product/19c/grid".
Cause: The Configuration Verification Utility (CVU) determined that the
Grid Infrastructure Management Repository (GIMR) database resource
configuration exists in the indicated source CRS home. Starting
with Oracle Database 23c, GIMR database is not supported.
Action: Ensure that the Grid Infrastructure Management Repository database
is deleted completely from the indicated source CRS home using the
commands ''srvctl stop mgmtdb -f; srvctl remove mgmtdb -f'' or run
the command ''<DEST_GI_HOME>/crs/install/reposScript.sh
-export_dir="location for export"'' from the destination CRS home
and retry the operation. Refer to My Oracle Support note 2972418.1
for more details.
Error message: Refer to My Oracle Support notes "2972418.1" for more details regarding errors "PRVH-1546".
Cause: Cause Of Problem Not Available
Action: User Action Not Available
[FATAL] [INS-13019] Some mandatory prerequisites are not met. These prerequisites cannot be ignored.
CAUSE: The following prerequisites are mandatory and cannot be ignored:
- Grid Infrastructure Management Repository cleanup.
ACTION: For detailed information of the failed prerequisites check the log: /u01/app/oraInventory/logs/GridSetupActions2026-10-02_04-51-40PM/gridSetupActions2026-10-02_04-51-40PM.log. Then either from the log file or from installation manual find the appropriate configuration to meet the prerequisites and fix it manually.
[oracle@rac-ol8-01 ~]$
FIX (as error already suggest):
[oracle@rac-ol8-01 ~]$ srvctl stop mgmtdb -f
[oracle@rac-ol8-01 ~]$ srvctl remove mgmtdb -f
[oracle@rac-ol8-01 ~]$
3: Error during “cluvfyrac.sh stage -pre crsinst”
[oracle@rac-ol8-01 ~]$ /u01/app/26ai/grid/bin/cluvfyrac.sh stage -pre crsinst -n rac-ol8-01
....
Failures were encountered during execution of CVU verification request "stage -pre crsinst".
Domain Sockets ...FAILED
....
....
"rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_agent_ag_CSSDAG_z"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_rac-ol8-01_GIPCD_lock"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_rac-ol8-01_GPNPD_lock"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_OHASD_soleowner_lock"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/mdnsd.pid" exists on node
"rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_rac-ol8-01_MOND"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_GPNPD_rac-ol8-01_lock"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_rac-ol8-01_MDNSD_lock"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_rac-ol8-01_CHAD"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File
"/var/tmp/.oracle/ora_gipc_scls_opct_rac-ol8-01_lock" exists on
node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File
"/var/tmp/.oracle/ora_gipc_monitor_ag_CSSDAG_z_lock" exists on node
"rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_rac-ol8-01_EVMD_lock"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_rac-ol8-01_LOGD"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_srac-ol8-01CRFM_SIPC"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File
"/var/tmp/.oracle/ora_gipc_srac-ol8-01CRFM_CLIIPC_lock" exists on
node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_rac-ol8-01_LOGD_lock"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_rac-ol8-01_GIPCD"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/mdnsd" exists on node
"rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_rac-ol8-01_CRSD_lock"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_gipcd_rac-ol8-01"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File
"/var/tmp/.oracle/ora_gipc_srac-ol8-01CRFM_MIIPC_lock" exists on
node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_rac-ol8-01_GPNPD"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/npohasd2" exists on node
"rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_rac-ol8-01_MOND_lock"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_rac-ol8-01_MDNSD"
exists on node "rac-ol8-01".
rac-ol8-01: PRVG-11750 : File "/var/tmp/.oracle/ora_gipc_GPNPD_rac-ol8-01"
exists on node "rac-ol8-01".
Grid Infrastructure home path: /u01/app/oracle/product/19c/grid ...FAILED
'/u01/app/oracle/product/19c/grid' ...FAILED
rac-ol8-01: PRVG-11931 : Path "/u01/app/oracle/product/19c/grid" is not
writeable on node "rac-ol8-01".
RPM Package Manager database ...INFORMATION
PRVG-11250 : The check "RPM Package Manager database" was not performed because
it needs 'root' user privileges.
Refer to My Oracle Support notes "2548970.1" for more details regarding errors
PRVG-11250".
ORAchk checks ...WARNING
Verify rngd system service ...WARNING
rac-ol8-01: AHF-4993: system service rngd is not running
Additional Error Details:
DATA FROM RAC-OL8-01 - VERIFY RNGD SYSTEM SERVICE
Redirecting to /bin/systemctl status rngd.service
Unit rngd.service could not be found.
CVU operation performed: stage -pre crsinst
Date: 02-Oct-2026 16:42:51
CVU version: 19.32.0.0.0 (070326x8664)
Clusterware version: 19.0.0.0.0
CVU home: /u01/app/oracle/product/19c/grid
Grid home: /u01/app/oracle/product/19c/grid
User: oracle
Operating system: Linux5.15.0-324.217.5.2.el8uek.x86_64
[oracle@rac-ol8-01 ~]$
Well… this is not an error. We are upgrading on a server currently running with the 19c version, so of course you have LOCK files and ORACLE_HOME locked (not writeable)
Comments